[Haskell-beginners] Important coding guideline and library
michael at snoyman.com
Sun Nov 22 14:32:13 EST 2009
I should think the more obvious examples would be last and init...
On Sun, Nov 22, 2009 at 9:26 PM, Joe Fredette <jfredett at gmail.com> wrote:
> Well then, on a similar note, I propose the following name changes:
> (+) is now
> (-) is the same, but with "Summation" changed to
> the `do` construct ought to be renamed
> Further, things like "unsafePerformIO" is not nearly descriptive enough,
> however, I leave it's appropriate renaming as an exercise to the reader...
> On Nov 22, 2009, at 2:15 PM, Daniel Fischer wrote:
>> NEVER, *never ever*, use 'length' ***unless you really want to know the
>> exact length of a
>> rename 'length' to
>> to reduce performance bugs caused by naive uses of length.
>> Beginners mailing list
>> Beginners at haskell.org
> Beginners mailing list
> Beginners at haskell.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Beginners