[Haskell-beginners] Important coding guideline and library proposal

Joe Fredette jfredett at gmail.com
Sun Nov 22 14:26:40 EST 2009

Well then, on a similar note, I propose the following name changes:

(+) is now  

(-) is the same, but with "Summation" changed to  

the `do` construct ought to be renamed  

Further, things like "unsafePerformIO" is not nearly descriptive  
enough, however, I leave it's appropriate renaming as an exercise to  
the reader...


On Nov 22, 2009, at 2:15 PM, Daniel Fischer wrote:

> Guideline:
> NEVER, *never ever*, use 'length' ***unless you really want to know  
> the exact length of a
> list***
> Proposal:
> rename 'length' to  
> 'yesIReallyWantToKnowTheExactLengthOfThisListSoPleaseCalculateItForMe'
> to reduce performance bugs caused by naive uses of length.
> _______________________________________________
> Beginners mailing list
> Beginners at haskell.org
> http://www.haskell.org/mailman/listinfo/beginners

More information about the Beginners mailing list