[arch-haskell] ghc 7.8.1 has hit [haskell-core]

Nicola Squartini tensor5 at gmail.com
Sun Apr 13 12:41:48 UTC 2014

I tried on another system and it works fine. It's definitely a problem of
this machine, but not a memory corruption because I have ecc and edac-util
shows 0 error corrections.

On Sun, Apr 13, 2014 at 1:05 PM, Bjørn Øivind Bjørnsen <
bo.bjornsen at gmail.com> wrote:

> On Sunday 13 April 2014 13:02:15 Nicola Squartini wrote:
> > Well, this is really weird! I even unistalled all haskell, cleared the
> > pacman cache and reinstalled ghc and hlint, and still I have that
> "Illegal
> > instruction". So it must be a problem of my system.
> >
> It may be a long shot, but have you tried dropping the kernel caches?
> Perhaps
> you have a bad stick of RAM or something.
> echo 3 > /proc/sys/vm/drop_caches
> as root should do the trick. You may also want to do a md5sum of the hlint
> binary before and after you do the above, to see if it makes a difference.
> Best Regards,
> Bjørn Øivind
> _______________________________________________
> arch-haskell mailing list
> arch-haskell at haskell.org
> http://www.haskell.org/mailman/listinfo/arch-haskell
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/arch-haskell/attachments/20140413/fc3ee1e0/attachment.html>

More information about the arch-haskell mailing list