[xmonad] Another data point on delays in focus update.

Don Stewart dons00 at gmail.com
Tue Mar 6 15:31:26 CET 2012

Does it happen with an out of the box xmonad ? With no user config?

On Tuesday, March 6, 2012, Allen S. Rout <asr at ufl.edu> wrote:
> A month or so ago, I posted about some slow focus updates I was seeing in
> http://article.gmane.org/gmane.comp.lang.haskell.xmonad/12074
> I noticed another correlation when this is happening, and thought I'd jot
it down in this forum, in the hopes that it eventually contributes to a
> During the period when the focus is slowly traversing a lot of
intervening windows, I've found that I peg a CPU running the X server; My
Xorg process goes to 99%CPU and stays there for the entirety of the delay.
> I've been watching the X cpu behavior because I've also noticed that some
Firefox browser behavior will similarly peg the Xorg process for seconds at
a time, and I was trying to suss that out.
> I'm kind of free-associating here, but I'm wondering if xmonad's use of X
resources is leaving Xorg with a long list of [wumpus]  that the X server
can't collect or collapse or something,  I have no idea what the wumpus
might be, but...
> - Allen S. Rout
> - Climbing back under his rock
> _______________________________________________
> xmonad mailing list
> xmonad at haskell.org
> http://www.haskell.org/mailman/listinfo/xmonad
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/xmonad/attachments/20120306/382b274f/attachment.htm>

More information about the xmonad mailing list