[xmonad] xmonad development

Allen S. Rout asr at ufl.edu
Wed Nov 9 21:48:53 CET 2011

On 11/07/2011 05:43 PM, Wirt Wolff wrote:

> Installation Steps
> * Install ghc, darcs, and if available, cabal-install through your
> distro.  Any combo of versions from the past 4 years or so that your
> distro has decided are compatible with one another are fine.
> * If cabal-īnstall isn't available in your repos, follow the simple
> instructions linked from the installation page:
>      http://www.haskell.org/haskellwiki/Cabal-Install#Unix
> * In a convenienct directory like ~/repos or the like, run the following
> commands:
>   $ darcs get http://code.haskell.org/xmonad

Fetching a hashed repository would be faster.  Perhaps you could persuade
the maintainer to run darcs optimize --upgrade with darcs 2.4.0 or higher?

>   $ darcs get http://code.haskell.org/XMonadContrib

Got the 'hash' message too, and also:

Finished getting.

Warning: CRC errors found. These are probably harmless but should be 
See 'darcs gzcrcs --help' for more information.

Blew away repo, re-darcs-ed it.    Same error.

But "it compiled, so it must be fine"... right? ;)

- Allen S. Rout

More information about the xmonad mailing list