[xmonad] Re: Issue 363 in xmonad: non-positive argument error on NVidia Xinerama set

codesite-noreply at google.com codesite-noreply at google.com
Sat Jan 23 07:02:20 EST 2010

Comment #5 on issue 363 by allbery.b: non-positive argument error on NVidia  
Xinerama set

As I understand it, cabal doesn't currently deal with updates and  
dependency checking because it's too easy to
get into "diamond dependency" issues.  (Package A updated, package B's deps  
specify old version, package C's
deps either specify new version or default version, package D tries to use  
packages B and C => bad things
happen; the only way to prevent this "automatically" would be to refuse to  
allow package A to be updated at all,
and if package D is installed later it must refuse to allow the install  
until someone fixes the dependency conflict

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

More information about the xmonad mailing list