[xmonad] xmobar-0.9.1 cannot compile

Don Stewart dons at galois.com
Wed Mar 11 01:49:52 EDT 2009

> hi,
> this is the output:
> 	 Configuring xmobar-0.9...
> 	 Warning: This package indirectly depends on multiple versions of the same
> 	 package. This is highly likely to cause a compile failure.
> 	 package X11-xft-0.3 requires utf8-string-0.3.3
> 	 package xmobar-0.9 requires utf8-string-0.3.4
> 	 Preprocessing executables for xmobar-0.9...
> 	 Building xmobar-0.9...
> 	 Linking dist/build/xmobar/xmobar ...
> 	 /usr/bin/ld: cannot find -lHSutf8-string-0.3.3
> different version of utf8-string are required. how to fix it?

ghc-pkg unregister utf8-string-0.3.3

then rebuild X11-xft and xmobar against only utf8-string-0.3.4.

If you're on Arch, sergej broke utf8-string when he upgraded, but that
was fixed 8 hours ago. 

-- Don

More information about the xmonad mailing list