[xmonad] another patch: modifies selection

Brent Yorgey byorgey at seas.upenn.edu
Fri Jan 2 14:47:03 EST 2009

On Fri, Jan 02, 2009 at 02:15:47PM -0500, Yaakov Nemoy wrote:
> 2009/1/2 Brent Yorgey <byorgey at seas.upenn.edu>:
> > On Fri, Jan 02, 2009 at 10:40:00AM -0500, Yaakov Nemoy wrote:
> >> 2009/1/1 Brent Yorgey <byorgey at seas.upenn.edu>:
> >> > On Sun, Dec 21, 2008 at 09:25:23PM -0500, Yaakov Nemoy wrote:
> >> >> Hey List,
> >> >>
> >> >> Here's another patch.  It modifies the XSelection module so you can
> >> >> pass a string modifying function to the promptSelect functions.  This
> >> >> lets you run your own escape routines for various reasons.
> >> >
> >> > These functions seem useful.  However, would you mind giving them
> >> > better names, adding some Haddock documentation, and resubmitting the
> >> > patch?  Also, why is the unsafe variant necessary?
> >>
> >> I'm not sure what to call them other than those names. The unsafe
> >> variant is necessary because there is an unsafe variant of the
> >> original function.  That said, the word 'unsafe' can be dropped from
> >> the function name. If you have any better names, just fill them in
> >> here, and i'll include them with my revised patch.
> >
> > Well, how about promptSelectionModify, promptSelectionModified,
> > promptSelectionTransform... just to suggest a few off the top of my
> > head.  The names you gave just seemed too long.  The names aren't
> > really that big of a deal in the end, though, the real showstopper was
> > the Haddock documentation.  As long as you add some nice documentation
> > I don't really care what you call the functions. =) The unsafe variant
> > is fine if it really is needed, I was just trying to understand the
> > difference between the two versions.
> I like transform.  I put it first because that's the order the actions
> happen. I've included the original patch in the file, so they can
> apply as one, or even be merged (i'm not sure how to do that in darcs,
> just in git.) I'm not sure the unsafe variant is 'needed', but i put
> it in for symmetry and completeness. Plus my cat was asking for it to
> be there, so i was happy to comply.

Applied, thanks.

> BTW, any comments about the other patch i submitted around the time of this one?

Hmm, which one was that?  I don't see another patch.


More information about the xmonad mailing list