[xmonad] Issue 229 in xmonad: WindowGo.runOrRaise does neither with hback program

codesite-noreply at google.com codesite-noreply at google.com
Fri Oct 24 04:06:30 EDT 2008

Issue 229: WindowGo.runOrRaise does neither with hback program

New issue report by wirtwolff:
What steps will reproduce the problem?
1. install hback from hackage, for simplicity copy to /usr/local/bin
2. bind a key to runOrRaise "hback" (className =? "Hback") and use it, with
or without hback running**

What is the expected output? What do you see instead?
Expect WindowGo.runOrRaise "hback" to run hback on current ws if not
already running, or switch view to ws it's running on.

Instead nothing seems to happen. On next X action 'Prelude.head: empty
list' is printed to stderr.

What version of the product are you using? On what operating system?
xmonad-0.8 xmonad-contrib-0.8-r1 gentoo

Please provide any additional information below.
twifkak mentioned Prompt.Shell.getCommands is likely source of error, a
(the?) relavent call to head.

** ManageHelpers.doCenterFloat on className =? "Hback" and
Prompt.runOrRaisePrompt hback both work correctly.

If this error is due to a module from XMonadContrib, please tag this issue
with 'Component-Contrib' below.


Issue attributes:
	Status: New
	Owner: ----
	Labels: Type-Defect Priority-Medium

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

More information about the xmonad mailing list