[Xmonad] keybinding not working after update to xorg-7.3

alexandre ac007 at bluewin.ch
Tue Sep 11 22:21:07 EDT 2007

Hello and thank you for your help !

I found an unexpected workaround : When i press ModMask+q (default
binding to "restart Nothing True") my buggy keybindings are back to
business !

Nevertheless, i gave it a try with my old ion3 and the xorg update to
7.3 also causes problems with the same keybinding : error message
"Mod4+agrave : could not convert keysym to keycode".

Le Mon, 10 Sep 2007 21:29:22 -0400,
"Brandon S. Allbery KF8NH" <allbery at ece.cmu.edu> a écrit :
> I would diff the Xkb databases between the two X11 versions; it looks  
> to me like they changed the keyboard mapping's behavior.

Following your advice, i tried to identify what changes could cause the
problem. Although a "diff -U 3 -r ${old-xkb} ${new-xkb}" gave me more than 9000
diff lines, nothing has changed for my xkb model/layout/variant -- or only
variants/options additions and such which i don't use. And in particular, the
'Super_L', 'agrave' and 'dollar' keysym/keycode are identical in both versions.
On the other hand, the xkb databases are rather cryptic to me and i probably
missed the changes which affects my keybindings.

Le Mon, 10 Sep 2007 22:03:01 -0400,
Alec Berryman <alec at thened.net> a écrit :
> I reverted my xkb-data package and things work fine; maybe that will work in
> your case.

I also tried to revert from the new xkeyboard-config to the old xkbdata, as you
suggested, but the keyboard would not work at all.

Anyway, thanks again for your inputs. I'll get along with my little
workaround till i'm abble to decrypt xkb stuff :]


More information about the Xmonad mailing list