[Xmonad] Re: darcs patch: add LayoutChoice module.

David Roundy droundy at darcs.net
Thu Sep 6 14:10:51 EDT 2007

On Thu, Sep 06, 2007 at 07:51:43PM +0200, Tassilo Horn wrote:
> David Roundy <droundy at darcs.net> writes:
> >> That's a functionality I missed since I switched to xmonad, so thanks
> >> a lot.  But I cannot apply the patch.  Darcs tells me:
> >
> > I presume the jumping straight to full-screen is what you've missed?
> Yes, and since I use 5 layouts which are all usefull in some scenarios
> it's not always possible to guess in what layout I am.  Tiled, mirror
> tiled, full and two-pane look similar for one window, and tiled and
> two-pane look similar for two windows.  So you have to learn the
> sequence of layouts in defaultLayouts and count from the first
> distinguishable layout when switching.

Yeah, it's been a bit of a challenge for me with a similar number of

Just out of curiosity, have you tried a simple combo/tabbed layout for your
two-pane? I find it much easier, as you can see what other windows are

                   , simpleStacking $
                     combo (twoPane 0.03 0.5) [(full,1),(tabbed shrinkText defaultTConf,1)]

> >> ,----
> >> | root at baldur /u/p/d/d/x/XMonadContrib# darcs apply /home/heimdall/add-layout…
> >> |                                      …choice-module_.dpatch
> >> | darcs failed:  Patch bundle failed hash!
> >> | This probably means that the patch has been corrupted by a mailer.
> >> | The most likely culprit is CRLF newlines.
> >> `----
> >> 
> >> But my emacs says the file has unix-eols.  What's the culprit?
> >
> > How did you save the patch from your email?
> `o' (`gnus-mime-save-part') on the attachment.

Hmmm.  That sounds reasonable.

> > Most likely that's when it got corrupted.
> Hm, that's the normal way I do it.  I tested it with another patch and
> it worked.

All I can think is that maybe for some reason gnus corrupts patches only
occasionally (e.g. I've run into scenarios in the past where mailers
corrupted patches containing a "From" at the beginning of a line).  But
I've very little idea what could be the problem.  Maybe you could send the
file you saved to me as an attachment? (Or put it up to be downloaded?)
David Roundy
Department of Physics
Oregon State University

More information about the Xmonad mailing list