[Xmonad] trouble with xmonad on OS X

Ben Weaver weaver at coptix.com
Thu Jun 28 08:54:33 EDT 2007


I've just installed xmonad on OS X, but I'm having trouble running it.
 When I start X11 and type "xmonad" into the terminal this error is

   xmonad: fatal error: request code=2, error code=10
   Error: BadAccess (attempt to access private resource denied)

I'm running these software versions:

   * OS X 10.4.10/ppc on a Powerbook G4
   * Apple's X11.app (1.1.3 -- XFree86 4.4.0)
   * ghc 6.6.1, installed from macports
   * X11-extras 0.2, installed manually
   * xmonad 0.2, installed manually

Could this be Xinerama-related?  I have a second display attached to
my laptop, but I've tried running xmonad without the second display
attached and it fails with the same error message.

When I configured the X11-extras package, these warnings were
generated (although it build successfully):

checking X11/extensions/Xinerama.h usability... no
checking X11/extensions/Xinerama.h presence... yes
configure: WARNING: X11/extensions/Xinerama.h: present but cannot be compiled
configure: WARNING: X11/extensions/Xinerama.h:     check for missing
prerequisite headers?
configure: WARNING: X11/extensions/Xinerama.h: see the Autoconf documentation
configure: WARNING: X11/extensions/Xinerama.h:     section "Present
But Cannot Be Compiled"
configure: WARNING: X11/extensions/Xinerama.h: proceeding with the
preprocessor's result
configure: WARNING: X11/extensions/Xinerama.h: in the future, the
compiler will take precedence
checking for X11/extensions/Xinerama.h... yes

If it helps, here is the console.log snippet generated when starting X11

XFree86 Version 4.4.0 / X Window System
(protocol Version 11, revision 0, vendor release 6600)
[DRI] screen 0 installation complete
Screen 0 added: 2304x1024 @ (0,0)
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/,
removing from list!

Any help is appreciated.

Best wishes,


More information about the Xmonad mailing list