[Xmonad] Issue 36 in xmonad: compile failure due to missing instance

codesite-noreply at google.com codesite-noreply at google.com
Sun Aug 5 20:21:30 EDT 2007

Issue 36: compile failure due to missing instance

Comment #2 by stefa... at cox.net:
Thanks for the report.

This appears to be a case of a documented issue with xmonad (in the README), where it has version dependencies on other packages finer than Cabal can express.  The .cabal file only says "X11-extras>=0.2", but not all X11-extras-0.2 are equal; xmonad darcs generally requires the newest darcs X11-extras.  The reason for this is that due to the incompleteness of X11, we need to frequently add new bindings to X11-extras as we add features to Xmonad; consequently there is an unfortunately tight synchronization between the two developments.

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

More information about the Xmonad mailing list