[web-devel] yesod init && wai-handler-devel

Balázs Endrész balazs.endresz at gmail.com
Mon Sep 5 15:29:28 CEST 2011

Hi everyone,

I've just tried Yesod for the first time, and managed to get the site
produced by the scaffolder working with wai-handler-devel. But currently
there seem to be a couple of issues with it:

1.) #ifdef WINDOWS macros doesn't work with wai-handler-devel, on Windows it
tries to load System.Posix.Signals in Application.hs

2.) in wai-handler-devel.hs I had to set the `yesod` field of the `Devel`
data type to True because otherwise it wouldn't work

3.) in Application.hs the withFoundation function takes two extra arguments,
so it produces a scary error message if one tries `wai-handler-devel 3000
Application withFoundation`. This can be solved with something like this:

withFoundation' f = do
    conf  <- Settings.loadConfig Settings.Development
    -- logger <- makeLogger
    let logger = undefined
    s <- static Settings.staticDir
    Settings.withConnectionPool conf $ \p -> do
        runConnectionPool (runMigration migrateAll) p
        let h = Foundation conf logger s p
        toWaiApp h >>= f

but then the logger produces some strange things:

  Interpreting success, new app loaded
  GET /
  Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  GET /static/css/normalize.css
  AccepGtE:T  t/esxtta/tciscs/,t*m/p*/;-qf=n0M.a15
  eGBE.Tc s[Gs(E
  "TAE cT/ckse7tp_atft:2i vct"/e,tx"mt"p/)/c]5s
  ccept: */*
  GET /favicon.ico
  Accept: */*
  AAAcccccceeepppttt:::   *tt/ee*xx

What could be the problem here?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/web-devel/attachments/20110905/b4c5d2a1/attachment.htm>

More information about the web-devel mailing list