[web-devel] yesod dependency hell

Michael Litchard michael at schmong.org
Wed Jun 22 22:50:24 CEST 2011

For further info, the build process stops after the warning below.
Here is my .cabal file. I would appreciate direction in how to resolve
this problem.
name:              Aframe
version:           0.0.1
license:           BSD3
license-file:      LICENSE
author:            Michael Litchard
maintainer:        Michael Litchard
synopsis:          The greatest Yesod web application ever.
description:       "Looks like your aframe is falling out. Cost you a million do
llars. And that's the labor"
category:          Web
stability:         Experimental
cabal-version:     >= 1.6
build-type:        Simple
homepage:          http://Aframe.yesodweb.com/

Flag production
    Description:   Build the production executable.
    Default:       False

Flag devel
    Description:   Build for use with "yesod devel"
    Default:       False

    if flag(devel)
        Buildable: True
        Buildable: False
    exposed-modules: Controller
    hs-source-dirs: ., config
    other-modules:   Aframe
executable         Aframe
    if flag(devel)
        Buildable: False

    if flag(production)
        cpp-options:   -DPRODUCTION
        ghc-options:   -Wall -threaded -O2
        ghc-options:   -Wall -threaded

    main-is:       config/Aframe.hs
    hs-source-dirs: ., config

    build-depends: base         >= 4       && < 5
                 , yesod-core   >= 0.8     && < 0.9
                 , yesod
                 , yesod-static
                 , yesod-form   >= 0.2
                 , wai-extra
                 , directory
                 , bytestring
                 , text
                 , template-haskell
                 , hamlet
                 , web-routes
                 , transformers
                 , wai
                 , warp
                 , blaze-builder
    ghc-options:   -Wall -threaded

On Wed, Jun 22, 2011 at 1:30 PM, Michael Litchard <michael at schmong.org> wrote:
> Configuring Aframe-0.0.1...
> Warning: This package indirectly depends on multiple versions of the same
> package. This is highly likely to cause a compile failure.
> package yesod-auth- requires yesod-form-
> package yesod- requires yesod-form-
> package Aframe-0.0.1 requires yesod-form-0.2.0
> I specified in Aframe.cabal yesod-form 0.2.0. The above warning is
> what I was looking to avoid. What is the solution to this problem? I
> could not find an obvious solution in yesodwiki.cabal, even though I
> see it's doing something similar to what I want. How did you deal with
> the above warning message?
> On Wed, Jun 22, 2011 at 12:32 PM, Michael Snoyman <michael at snoyman.com> wrote:
>> Have a look at the yesodwiki[1]; basically, you can't use the yesod
>> package itself, only the subpackages. This is by design so that a
>> single Yesod release will keep API stability, while users can still
>> experiment with newer versions of underlying packages.
>> Michael
>> [1] https://github.com/snoyberg/yesodwiki/blob/master/yesodwiki.cabal
>> On Wed, Jun 22, 2011 at 10:29 PM, Michael Litchard <michael at schmong.org> wrote:
>>> I need to use yesod-form 0.2.0. The problem is that the yesod package,
>>> and the yesod-auth package expect yesod-form to be 0.1.0*
>>> I tried changing the .cabal files but that breaks in ways that makes
>>> me think the fix is not so simple. How do I go about being able to use
>>> yesod-form 0.2.0
>>> _______________________________________________
>>> web-devel mailing list
>>> web-devel at haskell.org
>>> http://www.haskell.org/mailman/listinfo/web-devel

More information about the web-devel mailing list