[web-devel] Question about happstack

Jeremy Shaw jeremy at n-heptane.com
Tue Apr 20 15:24:19 EDT 2010

On Apr 20, 2010, at 9:02 AM, Kyle Murphy wrote:
> It also seems strange that this just started happening recently.  
> I've upgraded a number of packages recently, but I can't say for  
> sure what I changed since the last time I was able to compile  
> something based on happstack successfully. Is it possible that some  
> change with mtl or some other package is causing this error?

I am guessing that some of the libraries you depend on are compiled  
against one version of mtl, and some are compiled against another  
version. This is not an error in itself. However, you will run into  
issues similar to what you have described when GHC tries to use  
version of MonadIO from different versions of the mtl library.

Does "ghc-pkg describe mtl" show more than one version of mtl  
installed? What happens if you try to unregister the older version?

This seems like an issues with the state of your installed system, and  
not something happstack specific..

- jeremy
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/web-devel/attachments/20100420/3df5fb2e/attachment.html

More information about the web-devel mailing list