Haskell Foldable Wats

Edward Kmett ekmett at gmail.com
Thu Feb 25 11:49:44 UTC 2016


There are 4 different issues being brought up and conflated in this thread:

* Some people are complaining about the FTP entirely.
* Some people are complaining about adding instances they don't use.
* Some people are complaining about length.

Re: FTP as a whole

The FTP on the whole was and remains overwhelmingly popular. Frankly, the
vast majority, not all, but most of the users complaining in this thread
are the same people who were complaining about the FTP in the first place,
rehashing precisely the same arguments. The FTP itself passed with an
overwhelming 82% majority. If we can't act in the presence of that large of
a public majority, when _can_ we act?

Re: length

We DID see these so called "wats" when we decided the FTP. It made a small,
but noticeable, dip in the acceptance rate. Before the public reaction to
`length (1,2) = 1` , FTP was running at about 84% acceptance. Afterward a
series of posts pushed that issue, support dipped to 82% acceptance in
aggregate, and about half of the votes came in afterwards. So that is still
in 80% territory, even with the weird Data.List member story, and extra
members of Foldable, and every thing that was thrown against the wall
looking for something that would stick. Yes, these numbers aren't factored
out on all axes, and yes information diffusal wasn't perfect, but it does
show the relative scale of the issue against the FTP as a whole and
measurably deflate the "we didn't know about this" argument.

There is, however, a good reason to consider length a member of the
Foldable class. It avoids hoisting users on the dilemma of choosing between
what is portable and what is fast.

length in the class can give you O(1) answers for most containers foldl'
(+) 0 always pays O(n), getSum . foldMap Sum can be at best O(log n) but
will typically be O(n). The latter two always work, the former can always
be selected to be the optimal version for the container in question. If no
memoization is provided and no sharing is possible it can turn into the
foldl' form. If sharing is possible, then it can be the foldMap form. If a
size is carried for things like Data.Set or Data.Map it can be the O(1)
form.

That way if you want to, say, build a toVector function that takes any
Foldable container, you can use the length to size the array and get it as
quickly as possible, without having to balance the choice of 3 different
implementations and always having to worry that you are calling the wrong
one.

Given it to do over, I might have argued harder against the camp that
generalized length and null, and instead pushed to add new names, however,
that has to be balanced against the fact that we'd have another raft of
complaints about new symbols being taken by the Prelude, and that there
really, and the fact that there wasn't an objectively 'nice' set of names
available and that sniping between folks who wanted 'length' vs. something
like 'flength' would likely be just as vicious today.

APIs written after the addition of length/null to Foldable can elide
exporting their own length/null definitions and just use the one from the
Prelude, this reduces namespace pressure and the need for qualified
imports. As 7.8 falls out of the support window of more and more packages
it starts to become an option to drop existing null/size/length members for
many data types, similar to how some container types simply use empty from
Alternative as their empty value.

Re: instances you don't use

It has already been covered in this thread that the instances in question
are the only possible instance for the types involved.

The alternative is splintering the ecosystem with different sets of orphans
that provide precisely the same code. I, for one, would simply put an
orphan instance package at or near the bottom of the set of packages I
maintain and incur a dependency from day 1 were these somehow removed. I
use them throughout the code and libraries I write, and do not want to deal
with the ecosystem fragmentation. That would pretty much drag them back in
for a large percentage of Haskell users. This is simply a practical effect
of what I'd have to do to keep the packages I ship today working together.

We've already seen folks wrestling with where to get access to newer
instances we've added to base on older GHCs, and had to consolidate many
efforts on a base-orphans package. The direct reverse dependency list of
this fairly new package is quite small,

http://packdeps.haskellers.com/reverse/base-orphans

but the transitive dependency set is rather large. Getting it integrated
has required a huge number of retrofitted version bounds on hackage and
Herbert and Ryan have done yeoman's work fixing subtle build issue after
build issue caused by conflicting orphan sets.

We'd wind up in a similar situation for these instances.

Removing these instances would accomplish little other than ecosystem
fragmentation.

-Edward

On Wed, Feb 24, 2016 at 4:21 PM, Andreas Abel <abela at chalmers.se> wrote:

> Your example gives enough incentive to row back "the ship that has sailed"
> (to quote the favorite idiom on this list).
>
> It is very unfortunate that we did not see these Wats when we decided
> about FTP.
>
> The strong type checker of GHC is a major productivity tool for large code
> bases, and it would be a shame if we lost trust in it.
>
> My opinion as a GHC user is that deprecation of the features leading to
> these Wats should seriously be considered.  (Of course, as I am not a
> developer, and I will not do the work involved, I cannot make a strong
> case.)
>
> --Andreas
>
>
> On 24.02.2016 20:15, Andrew Farmer wrote:
>
>> Even this is problematic. Simplifying a bit, I managed to do this
>> recently:
>>
>>    module A (foo) where
>>    foo :: Bar -> [Int]
>>    foo = ... some hacky explicit recursion ...
>>
>>    module B where
>>    import A
>>    bar :: Bar -> Int
>>    bar = ... expression containing 'sum . foo' ...
>>
>> Then I noticed I had some calls to 'maximum' on the result of 'foo',
>> and wanted to just modify 'foo' to return the maximum value directly,
>> along with the list:
>>
>>    foo :: Bar -> ([Int], Int)
>>    foo = ...
>>
>> I went through and replaced the calls to 'maximum' with 'snd', but
>> forgot about 'sum'. GHC happily compiled my code, but was now
>> returning the maximum value instead of the sum of the values. This, of
>> course, caused some other bit to behave strangely, and took some calls
>> to 'trace' to figure out what was going on.
>>
>> There are lots of ways to avoid this... richer return type, use
>> Data.OldList, write some tests, more conscientious search and replace
>> refactoring... but the ease of refactoring code is one of the things I
>> love about Haskell. Normally, I can just change a type signature and
>> hit :r in ghci and start fixing type errors, confident that I've
>> covered my bases when it eventually compiles. Now I feel like I can't
>> rely on the typechecker as much.
>>
>> And yes, explaining the difference between maximum (2,1) and maximum
>> [2,1] to a beginner is a pain, and really weakens your claim that the
>> type system will prevent a lot of bugs in your code (at least in the
>> beginner's eyes).
>>
>> I don't know what the solution is... the instances are already there
>> and a lot of code relies on them, but I do feel like they fall on the
>> wrong side of the expressivity/safety line.
>>
>> On Wed, Feb 24, 2016 at 1:04 AM, Simon Peyton Jones
>> <simonpj at microsoft.com> wrote:
>>
>>> |  So, my advice is to use tuples only for very short-lived data, like
>>> |  returning multiple results from a function.
>>>
>>> I strongly agree, for all the reasons Andreas mentions.  GHC's source
>>> code has *lots* of data types that are isomorphic to tuples.  Crucial!
>>>
>>> Simon
>>>
>>> |  -----Original Message-----
>>> |  From: Libraries [mailto:libraries-bounces at haskell.org] On Behalf Of
>>> |  Andreas Abel
>>> |  Sent: 24 February 2016 08:58
>>> |  To: Nathan Bouscal <nbouscal at gmail.com>; libraries at haskell.org
>>> |  Subject: Re: Haskell Foldable Wats
>>> |
>>> |  In my n+1 years of participating in a 100kloc Haskell project, I
>>> |  learned that programming with the "categorical" data type building
>>> |  blocks "Either" and tuples leads to code that is hard to read and
>>> |  maintain.  It is tempting to use a pair
>>> |
>>> |     type QNamed a = (QName, a)
>>> |
>>> |  instead of a hand-rolled data type
>>> |
>>> |     data QNamed a = QNamed { qname :: QName, qnamedThing :: a }
>>> |
>>> |  since with pairs, I get lots of operations for free, and even more if
>>> I
>>> |  use Functor and Traversable, it seems.  However, in the long run, if I
>>> |  come back after months to my original code, or even worse, to someone
>>> |  else's code, I dearly pay for this:
>>> |
>>> |     1. Harder to read the code, as I may only see the non-telling "fst"
>>> |  and "snd" instead of the semantics-loaden "qname" and "qnamedThing".
>>> |
>>> |     2. Lack of code exploration facilities like grep and tags.  I can
>>> |  grep for "QName" and "qname", but grepping for "," and "fst" returns
>>> |  lots of irrelevant locations.
>>> |
>>> |     3. Non-telling error messages.
>>> |
>>> |  And all the arguments of using newtypes over type synonyms apply here
>>> |  as well.
>>> |
>>> |  So, my advice is to use tuples only for very short-lived data, like
>>> |  returning multiple results from a function.  I am speaking here of
>>> |  Haskell as a language for software development, not of Haskell as a
>>> |  realization of category theory.
>>> |
>>> |  For getting a broader acceptance of Haskell as a language for software
>>> |  development, Foldable on tuples is not helpful.
>>> |
>>> |  And yes, if I was new to Haskell and learned the GHCI thinks that
>>> |
>>> |     minimum (1,2) == 1
>>> |
>>> |  then I would advice GHCI to visit some mental institution to get its
>>> |  delusions fixed.
>>> |
>>> |  --Andreas
>>> |
>>> |
>>> |  On 23.02.2016 18:29, Nathan Bouscal wrote:
>>> |  > Sorry, poor quoting on my part. I was attempting to reply to
>>> |  Andreas's
>>> |  > earlier points:
>>> |  >
>>> |  >  >> Use of tuples is highly discourageable…
>>> |  >>>I see no point in Functor or Foldable for tuples.
>>> |  >
>>> |  > On Tue, Feb 23, 2016 at 5:18 PM, Mario Blažević <
>>> mblazevic at stilo.com
>>> |  > <mailto:mblazevic at stilo.com>> wrote:
>>> |  >
>>> |  >     On 16-02-23 11:23 AM, Nathan Bouscal wrote:
>>> |  >
>>> |  >         It's a bit bold to simultaneously say "Nobody should use
>>> this
>>> |  >         type," and
>>> |  >         also "If you use this type, you should do it this way." If
>>> |  you think
>>> |  >         that it's bad practice to use tuples, that's a fine and
>>> |  respectable
>>> |  >         opinion, but at that point you should start being a bit more
>>> |  >         wary about
>>> |  >         telling those who think otherwise /how/ they should use
>>> them.
>>> |  >
>>> |  >
>>> |  >              I believe he was referring to lists, not to tuples.
>>> |  There
>>> |  >     were  few Prelude functions limited to tuples before FTP, and
>>> |  those
>>> |  >     haven't changed.
>>> |  >
>>> |  >
>>> |  >
>>> |  >         On Tue, Feb 23, 2016 at 1:10 PM, Marcin Mrotek
>>> |  >         <marcin.jan.mrotek at gmail.com
>>> |  >         <mailto:marcin.jan.mrotek at gmail.com>
>>> |  >         <mailto:marcin.jan.mrotek at gmail.com
>>> |  >         <mailto:marcin.jan.mrotek at gmail.com>>> wrote:
>>> |  >
>>> |  >              > I can assure you that Andreas is not delusional
>>> |  >
>>> |  >              I didn't say that. I was referring to his response to
>>> my
>>> |  >         post, that
>>> |  >              "Some delusions have very sophisticated explanations."
>>> |  >
>>> |  >              > You have to show good taste or you'll end up with a
>>> |  mess
>>> |  >         that might be logically consistent, but unpleasant to use.
>>> |  >
>>> |  >              This is entirely subjective, and frankly I don't think
>>> |  that
>>> |  >         post-FTP
>>> |  >              Haskell is a "mess" or is "unpleasant to use". If
>>> |  anything,
>>> |  >         it became
>>> |  >              more useful to me, because now Prelude functions aren't
>>> |  >         limited to the
>>> |  >              one data structure I almost never use.
>>> |  >
>>> |  >              Best regards,
>>> |  >              Marcin Mrotek
>>> |  >
>>> |  >
>>> |  >     _______________________________________________
>>> |  >     Libraries mailing list
>>> |  >     Libraries at haskell.org <mailto:Libraries at haskell.org>
>>> |  >
>>> |  >
>>> |
>>> https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fmail.h
>>> |  > askell.org%2fcgi-
>>> |  bin%2fmailman%2flistinfo%2flibraries&data=01%7c01%7cs
>>> |  >
>>> |  imonpj%40064d.mgd.microsoft.com
>>> %7ce4033ee9a03a42eaa97108d33cf89187%7c7
>>> |  >
>>> |  2f988bf86f141af91ab2d7cd011db47%7c1&sdata=hgiQqaz1dUG2aUrmeYETcy6loEMf
>>> |  > xosR3yBA09CQaZs%3d
>>> |  >
>>> |  >
>>> |  >
>>> |  >
>>> |  > _______________________________________________
>>> |  > Libraries mailing list
>>> |  > Libraries at haskell.org
>>> |  >
>>> |
>>> https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fmail.h
>>> |  > askell.org%2fcgi-
>>> |  bin%2fmailman%2flistinfo%2flibraries&data=01%7c01%7cs
>>> |  >
>>> |  imonpj%40064d.mgd.microsoft.com
>>> %7ce4033ee9a03a42eaa97108d33cf89187%7c7
>>> |  >
>>> |  2f988bf86f141af91ab2d7cd011db47%7c1&sdata=hgiQqaz1dUG2aUrmeYETcy6loEMf
>>> |  > xosR3yBA09CQaZs%3d
>>> |  >
>>> |
>>> |
>>> |  --
>>> |  Andreas Abel  <><      Du bist der geliebte Mensch.
>>> |
>>> |  Department of Computer Science and Engineering Chalmers and Gothenburg
>>> |  University, Sweden
>>> |
>>> |  andreas.abel at gu.se
>>> |
>>> https://na01.safelinks.protection.outlook.com/?url=http:%2f%2fwww2.tcs.
>>> |  ifi.lmu.de%2f~abel%2f&data=01%7C01%7Csimonpj%40064d.mgd.microsoft.com
>>> %7
>>> |
>>> Ce4033ee9a03a42eaa97108d33cf89187%7C72f988bf86f141af91ab2d7cd011db47%7C
>>> |  1&sdata=kvwlaXofxhQV2ZCD9K%2bemtG4S9oCujNYhn1IXTnSZtc%3d
>>> |  _______________________________________________
>>> |  Libraries mailing list
>>> |  Libraries at haskell.org
>>> |
>>> https://na01.safelinks.protection.outlook.com/?url=http%3a%2f%2fmail.ha
>>> |  skell.org%2fcgi-
>>> |
>>> bin%2fmailman%2flistinfo%2flibraries%0a&data=01%7c01%7csimonpj%40064d.m
>>> |  gd.microsoft.com
>>> %7ce4033ee9a03a42eaa97108d33cf89187%7c72f988bf86f141af9
>>> |
>>> 1ab2d7cd011db47%7c1&sdata=gMTA2SOTm1seAHbvHPWnsDjAa7y1gAS681kW6YUx1mQ%3
>>> |  d
>>> _______________________________________________
>>> Libraries mailing list
>>> Libraries at haskell.org
>>> http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries
>>>
>>
> --
> Andreas Abel  <><      Du bist der geliebte Mensch.
>
> Department of Computer Science and Engineering
> Chalmers and Gothenburg University, Sweden
>
> andreas.abel at gu.se
> http://www2.tcs.ifi.lmu.de/~abel/
>
> _______________________________________________
> Libraries mailing list
> Libraries at haskell.org
> http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/libraries/attachments/20160225/fff8ebe4/attachment-0001.html>


More information about the Libraries mailing list