[Mid-discussion Summary] Proposal: add new Data.Bits.Bits(bitZero) method

Mikhail Vorozhtsov mikhail.vorozhtsov at gmail.com
Wed Feb 26 20:39:44 UTC 2014

Wanna paint this bikeshed too! I used `allZeroes` and `allOnes` here[1].


On 02/25/2014 01:12 AM, Ian Lynagh wrote:
> On Sat, Feb 22, 2014 at 02:51:24PM -0500, Anthony Cowley wrote:
>> I am -1 on the name zero. I don't think importing Data.Bits unqualified is uncommon at all, and zero is prime naming real estate. I am +0.5 on the addition overall, as most uses of Bits are with types that also have Num instances.
> For those that don't have a Num instance, "zero" may not make as much
> sense.
> Perhaps something like noBits would be better. And FiniteBits may also
> want an allBits?
> Thanks
> Ian
> _______________________________________________
> Libraries mailing list
> Libraries at haskell.org
> http://www.haskell.org/mailman/listinfo/libraries

More information about the Libraries mailing list