[Mid-discussion Summary] Proposal: add new Data.Bits.Bits(bitZero) method

Casey McCann cam at uptoisomorphism.net
Tue Feb 25 13:55:11 UTC 2014

On Tue, Feb 25, 2014 at 1:23 AM, Gershom Bazerman <gershomb at gmail.com> wrote:
> The issue isn't about qualified or unqualified names at all. It is about
> names which express intent clearly and evocatively, and names which are
> unacceptably ambiguous.
> As such, I propose
> zero --> whereDidTheBitsGo
> and conversely,
> allBits --> iHaveAllTheBits
> It seems to me that these are expressive names with unmistakable meanings.

Well, for names in that vein, I'd suggest notOneBit and everyLastBit.
This avoids reinventing the wheel by relying on standard English
idioms, and it's well-known that imitating the flawless logical
structure of the English language is the highest goal for any
programming language.

- C.

More information about the Libraries mailing list