[Proposal] Renaming (:=:) to (==)

Shachaf Ben-Kiki shachaf at gmail.com
Sun Sep 29 02:08:45 UTC 2013

On Sat, Sep 28, 2013 at 6:57 PM, Edward Kmett <ekmett at gmail.com> wrote:
> As part of the discussion about Typeable, GHC 7.8 is going to include a
> Data.Type.Equality module that provides a polykinded type equality data
> type.
> I'd like to propose that we rename this type to (==) rather than the (:=:)
> it was developed under.
> We are already using (+), (-), (*), etc. at the type level in type-nats, so
> it would seem to fit the surrounding convention.
> I've done the work of preparing a patch, visible here:
> https://github.com/ekmett/packages-base/commit/fb47f8368ad3d40fdd79bdeec334c0554fb17110
> Thoughts?
> Normally, I'd let this run the usual 2 week course, but we're getting down
> to the wire for 7.8's release. Once 7.8 ships, we'd basically be stuck with
> the current name forever.
> Discussion Period: 1 week
> -Edward Kmett

+1. For what it's worth, I suggested that name before, and Richard
Eisenberg suggested that == should be for type-level Boolean equality:
<http://markmail.org/message/3yifytgt2k3cfwws>. I'm not convinced,
though -- this seems fundamental enough to deserve the simplest name

(I'm using that link because the haskell.org mailing list archive
seems to be gone... Hopefully that comes back, eventually.)


More information about the Libraries mailing list