Proposal: Add bool to Data.Bool
dag.odenhall at gmail.com
Wed Sep 11 00:07:39 CEST 2013
Not when we have maybe and either with those names already.
On Wed, Sep 11, 2013 at 12:05 AM, Carter Schonwald <
carter.schonwald at gmail.com> wrote:
> just to add a bit of bikeshedding, wouldn't it better be called something
> like boolElim ?
> On Tue, Sep 10, 2013 at 6:02 PM, Oliver Charles <ollie at ocharles.org.uk>wrote:
>> I would like to propose that the following is added to Data.Bool in base:
>> bool :: a -> a -> Bool -> a
>> bool f _ False = f
>> bool _ t True = t
>> (Aka, bool f t b = if b then t else f)
>> The purpose of this is hopefully evident from its definition. I find
>> myself reaching for this in cases similar to where I would use 'maybe' -
>> often when I'm working with 'fmap' and don't want to start introducing
>> names for the function I am using to map over some functor.
>> I suggested this in #haskell and other people also seem frustrated this
>> doesn't exist, and would like to see it happen - hopefully they will
>> voice their support as a reply here.
>> A quick search on FPComplete's Hoogle  shows five equivalent
>> functions on the first page - and I'm sure there are more on subsequent
>> - ocharles
>> Libraries mailing list
>> Libraries at haskell.org
> Libraries mailing list
> Libraries at haskell.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Libraries