Wither Haskell Platform 2013.4.0.0

Isaac Dupree ml at isaac.cedarswampstudios.org
Mon Oct 14 00:05:43 UTC 2013

On 10/13/2013 04:03 PM, Mark Lentczner wrote:
> You'll have to ask the Yale music crowd why it isn't on Hackage.... But,
> their web site does have a page on how to get it:
> http://haskell.cs.yale.edu/euterpea/download/  But it basically boils
> down to getting it from github: https://github.com/Euterpea/Euterpea -
> If I recall, it has one or two dependencies that didn't build on the
> latest HP, but just required tweaking of their .cabal files to fix....
> Wish I had written that down when I started!

Euterpea's Setup.hs imports the local ArrowWrap.hs which requires 
haskell-src-exts < 1.14.0.  Euterpea.cabal specifies haskell-src-exts == 
1.13.5, but 'cabal configure' doesn't apply that requirement to 
compiling Setup.hs.

I ran 'cabal install haskell-src-exts-1.13.5' then 'ghc-pkg unregister 
haskell-src-exts-1.14.0' to fix this, but maybe there's a better way.

I didn't have any other trouble building Euterpea or PlainChanges2 
(after cabal installing the dependency versions that Euterpea.cabal asks 

Once I built it, this worked for me on my Linux to listen to it:
$ ./dist/build/plainchanges2/plainchanges2 midi .
$ timidity whole-composed.midi

(SoundCloud claims to require Flash, which I avoid installing, so I 
couldn't listen to it there.)

By the way, on 
https://github.com/mzero/PlainChanges2/blob/master/doc/Building.md the 
link to Euterpea's website is broken.

-Isaac (because I'm interested in computer-generated/mediated sound)

More information about the Libraries mailing list