proposal/RFC: add bSwap to base in Data.Bits
nominolo at googlemail.com
Thu May 16 11:00:11 CEST 2013
I'd strongly prefer "byteSwap". We already have shiftR, shiftL insted
of sh[a]r, shl; I see no reason to stick to assembly convention here.
Also "bSwap" still wouldn't make it clear that it's _byte_ swap rather
than _bit_ swap.
On 16 May 2013 10:55, Vincent Hanquez <tab at snarc.org> wrote:
> On Thu, May 16, 2013 at 04:32:41AM -0400, Edward Kmett wrote:
>> I would be strongly against naming it 'swap'. Lots of people in the
>> community do not subscribe to the philosophy that all things should be
>> imported qualified.
>> 'byteSwap' or even 'byteswap' would be closer to the traditional 'bswap'
>> name in spirit.
> I thought about byteswap too, and i think it's a fine choice (although my
> preference still goes on bswap for now). If a majority prefer byteswap to
> bswap, i'm happy to change it.
> Libraries mailing list
> Libraries at haskell.org
More information about the Libraries