proposal/RFC: add bSwap to base in Data.Bits

Vincent Hanquez tab at
Thu May 16 10:55:09 CEST 2013

On Thu, May 16, 2013 at 04:32:41AM -0400, Edward Kmett wrote:
> I would be strongly against naming it 'swap'. Lots of people in the
> community do not subscribe to the philosophy that all things should be
> imported qualified.
> 'byteSwap' or even 'byteswap' would be closer to the traditional 'bswap'
> name in spirit.

I thought about byteswap too, and i think it's a fine choice (although my
preference still goes on bswap for now). If a majority prefer byteswap to
bswap, i'm happy to change it.


More information about the Libraries mailing list