Proposal: Slim base-5 API package

Henning Thielemann lemming at
Mon Jul 15 23:08:26 CEST 2013

On Mon, 15 Jul 2013, Joachim Breitner wrote:

> Do you have a suggestion for a better name than pure-base?
> pure-unreal-world, as there is no notion of the RealWorld# state
> token ;-)?

You know, finding identifiers is one of the most difficult problems in 
computer science.

The first names that come to my mind are all negating, like base-non-io, 
base-non-monadic (but I think Control.Monad could be part of the package). 
I'd prefer a positive name, since I think non-IO code should be the normal 
case in Haskell and I/O the exception. base-basic, base-simple, 
base-plain, base-core, base-tame, base-gentle (won't launch dangerous 
things) - I don't know.

More information about the Libraries mailing list