Proposal: Add (&) to Data.Function

Andreas Abel andreas.abel at
Tue Nov 20 18:32:43 CET 2012

On 20.11.2012 18:25, Johan Tibell wrote:
> On Tue, Nov 20, 2012 at 9:19 AM, Dan Burton < at
> < at>> wrote:
>     I agree that Haskell should provide this idiom. I find & to be a
>     strange name for it, but to be honest, it's no stranger than $ so I
>     say go for it. I would suggest | to mimic the unix pipe, but this
>     obviously clashes with Haskell guard syntax. I think |> is a
>     reasonable name, but Data.Sequence has already claimed it.
> I also like |> for the color of this shed, as there's prior art for it.
>  > but Data.Sequence has already claimed it.
> We should use namespaces for these things instead of trying to come up
> with globally unique names (be they symbols). Trying to be globally
> unique doesn't scale to large codebases and eventually gives =>@@@@#$>. ;)


Andreas Abel  <><      Du bist der geliebte Mensch.

Theoretical Computer Science, University of Munich
Oettingenstr. 67, D-80538 Munich, GERMANY

andreas.abel at

More information about the Libraries mailing list