Announce: Haskell Platform 2012.4.0.0

Matthias Kilian kili at
Wed Nov 7 23:09:04 CET 2012

[lists cc: trimmed down dow haskell-platform@ and libraries@]


On Mon, Nov 05, 2012 at 11:54:05PM -0800, Mark Lentczner wrote:
> I'm pleased to announce that Haskell Platform
> 2012.4.0.0<>is
> now available.

Small safety hint for distributors: the haskell-platform.cabal file
mandates network == and HTTP == 4000.2.5, but the latter
by default depends on  network >= 2.4 && < 2.5. So if you want to
avoid to include the same package in different versions (which at
least OpenBSD does), you'll have to configure HTTP with -fnetwork23
(which changes the dependency to network < 2.4).


More information about the Libraries mailing list