Proposal: add 'findLess' and variants to containers
wren ng thornton
wren at freegeek.org
Sat Mar 3 09:58:28 CET 2012
On 3/2/12 7:43 PM, David Waern wrote:
> 2012/3/3 Thomas Schilling<nominolo at googlemail.com>:
>> I'm generally +1, but I still don't really like the names "lookupLess"
>> or "findLess". It just doesn't invoke the right association. Maybe
>> something that shows the relation to findMin/Max? E.g., something
>> more along the lines of "lookupMaxBelow", "lookupMinAbove".
> +1 for lookupMaxBelow and lookupMinAbove (and lookupMaxBelowEqual /
If we go with min/max terminology rather than lt/le/gt/ge, might I
suggest rather: lookupMaxNotAbove / lookupMinNotBelow ? "Below equal"
and "above equal" is mixing metaphors.
More information about the Libraries