Proposal: add 'findLess' and variants to containers
nominolo at googlemail.com
Sat Mar 3 01:20:36 CET 2012
I'm generally +1, but I still don't really like the names "lookupLess"
or "findLess". It just doesn't invoke the right association. Maybe
something that shows the relation to findMin/Max? E.g., something
more along the lines of "lookupMaxBelow", "lookupMinAbove".
On 2 March 2012 18:52, Twan van Laarhoven <twanvl at gmail.com> wrote:
> On 12/02/12 14:14, Twan van Laarhoven wrote:
>> Discussion deadline: 2 weeks from now; Sunday, 26 February 2012.
> The deadline for discussion has passed. There were no explicit votes for or
> against, but 4 reactions that count as positive, and 1 as unconvinced.
> The only issue seems to be the names:
>> Thanks for the benchmark. In light of this and your other arguments I
>> think we should add the functions. Lets settle on the names.
> I have made a case for /lookup(Less|Greater)(Equal)?/, based on the fact
> that lookup* functions return "Maybe x" values, while find* functions return
> values without a maybe wrapper. But I don't really care that much. Flipping
> a coin between "find" and "lookup" will also work for me :)
> Libraries mailing list
> Libraries at haskell.org
Push the envelope. Watch it bend.
More information about the Libraries