Haskell platform proposal: split package

Bryan O'Sullivan bos at serpentine.com
Mon Jul 23 18:22:56 CEST 2012

On Fri, Jul 20, 2012 at 1:35 PM, Brent Yorgey <byorgey at seas.upenn.edu>wrote:

> Everyone is invited to review this proposal, following the standard
> procedure [2] for proposing and reviewing packages.

My comments:

I'm generally in favour of this, as the split library is quite nice. A
couple of more specific notes follow.

Would you have any interest in abstracting this library over other
particularly common list-like sequences? There's obviously a need for
similar functionality with e.g. the text and bytestring libraries (maybe
vector too, though I'm more dubious), and proliferating this API into those
packages doesn't seem like the best way to go.

Speaking of the text library, it already provides a function named chunksOf
that is identical to your splitEvery:


For consistency with an existing HP library, I think you should rename
splitEvery to chunksOf.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/libraries/attachments/20120723/83cd8969/attachment.htm>

More information about the Libraries mailing list