generalization of maybeToList
ekmett at gmail.com
Wed Feb 15 16:59:47 CET 2012
On Tue, Feb 14, 2012 at 8:03 PM, Jeff Shaw <shawjef3 at msu.edu> wrote:
> If we want to argue about maybeTo and the Fairbairn threshold, probably we
> should argue about whether to include maybeToList, which is less general
> than maybeTo.
This is a much harder sell, because it has to overcome the fact that such a
change for the sake of intellectual purity would break existing code
The fact that this becomes a consideration is further argument against
carelessly expanding the library.
I'm not saying that the combinators under discussion are a careless
expansion, merely that their addition needs to be weighed against those
I'm still a lukewarm +1 for adding maybeTo/maybeA if better names can be
derived. Annoyingly it doesn't fit any of the m prefix or M suffix
guidelines in Control.Monad, so the obvious maybeM or mmaybe would be
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Libraries