Messed up with Cabal on Mac

Daniel Fischer at
Sun May 8 19:28:51 CEST 2011

On Sunday 08 May 2011 18:57:19, Harad wrote:
> Hello everybody,
> I was trying to install `snap` but I was getting this error:
> <command line>: cannot satisfy -package-id
> haskell98-
> I still don't fully understand why was this happening but, reading
> here and there, I ended up running `ghc-pkg unregister --user
> haskell98`. Some of you may be facepalming at this point, because then
> if I ran `ghc-pkg check` I got a really, really long list of broken
> packages.

If you didn't use --force, those packages would have been broken before, 
ghc-pkg shouldn't unregister packages if that would break others without 
the --force flag.

> So I decided to throw it all away, removed the whole Haskell
> Platform from my computer as told here <> (I know,
> pretty Mac-ish solution), installed it back... but I continue getting
> the same error when installing `snap`, and `ghc-pkg check` still
> throws me this infinite list: .

Looks like you removed your ~/.cabal, but haven't removed your user 

The best I know is to remove ~/.ghc/[version]/package.conf.d, so your ghc 
only knows about the global packages and then reinstall the user packages.
That will take a while, but as is, your setup seems completely broken.

> I searched but I didn't find any posible solution. Do you have any
> idea of how can I clean up all that mess? Thanks in advance!
> (If my English is awful is because I'm Spanish and Spanish people are
> the worse language learners in the world, so I'm sorry for that.)

P.S.: This sort of problem should better go to haskell-cafe rather than 
libraries, I think.

More information about the Libraries mailing list