Messed up with Cabal on Mac

Harad haradsul at
Sun May 8 18:57:19 CEST 2011

Hello everybody,

I was trying to install `snap` but I was getting this error:

<command line>: cannot satisfy -package-id

I still don't fully understand why was this happening but, reading
here and there, I ended up running `ghc-pkg unregister --user
haskell98`. Some of you may be facepalming at this point, because then
if I ran `ghc-pkg check` I got a really, really long list of broken
packages. So I decided to throw it all away, removed the whole Haskell
Platform from my computer as told here <> (I know,
pretty Mac-ish solution), installed it back... but I continue getting
the same error when installing `snap`, and `ghc-pkg check` still
throws me this infinite list: .

I searched but I didn't find any posible solution. Do you have any
idea of how can I clean up all that mess? Thanks in advance!

(If my English is awful is because I'm Spanish and Spanish people are
the worse language learners in the world, so I'm sorry for that.)

More information about the Libraries mailing list