question about cabal

Bryan O'Sullivan bos at
Wed Jan 26 22:50:08 CET 2011

On Wed, Jan 26, 2011 at 1:35 PM, Kathleen Fisher
<kathleen.fisher at>wrote:

> >  ~/.cabal/bin/cabal install -w ~/sw/ghc-7.01/bin/ghc
> --package-db=/Users/kfisher/sw/ghc-7.01/lib/ghc-7.0.1/package.conf.d
> I get the following error messages:
> > Resolving dependencies...
> > cabal: cannot configure mainland-pretty- It requires containers
> >=0.2
> > && <0.4

See here that mainland-pretty has excluded containers 0.3? That's your
problem - GHC 7 ships with containers 0.4.

That's question number one: why is it trying to configure a library that is
> already installed?

Because it's trying, and failing, to meet a set of internally inconsistent
version dependency constraints.

That's the second question: why does cabal install not work while breaking
> it into pieces does work?

By breaking the install into pieces, you're letting the package manager see
only a small fraction of the dependency graph at a time, and those
disconnected pieces of the graph are not themselves internally inconsistent.
It's when cabal gets a holistic look at the lot that everything goes
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Libraries mailing list