[GHC] #4517: Add Data.Functor.Backwards to transformers

kahl at cas.mcmaster.ca kahl at cas.mcmaster.ca
Sun Nov 21 21:10:15 EST 2010

 > Can I ask that the name Reverse not be used? I have a newtype wrapper 
 > for Ord by that name which I'm planning to propose adding to base (in a 
 > month or so, once the semester ends so I have the time). I can't think 
 > of another good name for the obvious Ord transformer, 

As far as an Ord instance represents a relation,  ``Converse'' would be a
natural name for something representing the converse relation.


More information about the Libraries mailing list