Haskell Platform call for consensus: add transformers and revise the mtl package to depend on it

Yitzchak Gale gale at sefer.org
Tue Nov 16 07:21:17 EST 2010

I wrote:
>> Please create a document (perhaps on the wiki?) with clear
>> instructions how to resolve any incompatibilities for the upgrade.

Ross Paterson wrote:
> The "Upgrading to mtl-2" section in the above-linked page is a start
> in this direction.

Great! I copied some of that content to the wiki:


Please update the cabal file so that a link to this
content appears in the package description on Hackage.

On the wiki, I linked to these from the MTL page:


These pages are kind of a rough transcription from wiki to wiki.
Anyone who can pretty it up is encouraged to do so.

The MTL page sorely needs a brief description of the
various monad libraries and the relationships between

mtl-1, mtl-2, monads-fd, monads-tf, mtl-tf, transformers,


More information about the Libraries mailing list