Haskell Platform call for consensus: add transformers and revise the mtl package to depend on it

Judah Jacobson judah.jacobson at gmail.com
Thu Nov 4 13:22:24 EDT 2010

On Thu, Nov 4, 2010 at 10:05 AM, Ross Paterson <ross at soi.city.ac.uk> wrote:
> On Thu, Nov 04, 2010 at 05:39:29PM +0100, Johan Tibell wrote:
> % cabal install --dry-run atomo-0.2
> Resolving dependencies...
> cabal: cannot configure monads-fd- It requires mtl ==2.*
> For the dependency on mtl ==2.* there are these packages: mtl- However
> none of them are available.
> mtl- was excluded because haskeline- requires mtl ==1.1.*
> This will become more common as more packages are upgraded to mtl-2.

For what it's worth, that's been fixed by the just-uploaded
haskeline-  (I was pleased to discover that I only needed to
bump the constraint in its build-depends.)


More information about the Libraries mailing list