proposed change to transformers package

Ross Paterson ross at
Fri Mar 26 08:15:24 EDT 2010

On Tue, Mar 23, 2010 at 02:37:54PM +0000, Ross Paterson wrote:
> I propose to rename some of the modules in the transformers package so
> that it no longer conflicts with the mtl package:
>   Control.Monad.Identity renamed as Data.Functor.Identity
>   Control.Monad.Trans split between Control.Monad.Trans.Class and
>         Control.IO.Trans.Class
> Then Control.Monad.Identity and Control.Monad.Trans are added to monads-fd
> making it closer to mtl.

Now done.  I also added Data.Functor.{Constant,Compose} to transformers.

More information about the Libraries mailing list