packedstring should depend on base >= 4

José Pedro Magalhães jpm at
Tue Feb 2 03:06:55 EST 2010

Hello all,

While installing packedstring:

> cabal install packedstring
> Resolving dependencies...
> Configuring packedstring-
> Preprocessing library packedstring-
> Building packedstring-
> Data\PackedString.hs:83:7:
>     Could not find module `Data.Data':
>       It is a member of the hidden package `base'.
>       Perhaps you need to add `base' to the build-depends in your .cabal
> file.
>       Use -v to see a list of the files searched for.
> cabal: Error: some packages failed to install:
> packedstring- failed during the building phase. The exception was:
> ExitFailure 1
> > cabal install packedstring --preference="base >= 4"

Then it installs fine. Shouldn't the constraint "base >= 4" be added to the
packedstring package? I know it's deprecated, but many things depend on it (,
namely template-haskell...

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Libraries mailing list