ganesh.sittampalam at credit-suisse.com
Thu Nov 19 06:52:48 EST 2009
Yitzchak Gale wrote:
> Simon Marlow wrote:
>> So then what shall we call the a -> () version?
>> One possibility is to go back to calling it rnf.
> In light of apfelmus' comment, I vote for rnf.
> And in that case, how about the analogous alternative for seq itself:
> hnf :: a -> ()
I think it would be whnf since it doesn't evaluate under lambdas.
I also vote for rnf, because we should have a good reason for changing
names of things.
Please access the attached hyperlink for an important electronic communications disclaimer:
More information about the Libraries