marlowsd at gmail.com
Thu Nov 19 06:36:12 EST 2009
On 18/11/2009 12:12, Ian Lynagh wrote:
> On Wed, Nov 18, 2009 at 09:17:31AM +0000, Simon Marlow wrote:
>> I don't feel terribly strongly, but I have a slight preference for the
>> current version.
> I think something like
> deepseq :: a -> (a -> b) -> b
> would be best, so that it doesn't suffer from
I don't mind supplying that too, with a comment to explain why it's
there. Although we could recommend that people use the bang-pattern
idiom instead, where that's available.
The main question still to be resolved is what names to use. I agree
with Duncan's point that deepseq should have the same type as seq, to
reduce confusion. So then what shall we call the a -> () version?
One possibility is to go back to calling it rnf. Any other ideas?
More information about the Libraries