Advance warning to package authors of breakage

Duncan Coutts duncan.coutts at
Mon Nov 16 07:37:19 EST 2009

On Mon, 2009-11-16 at 03:49 +0100, Svein Ove Aas wrote:
> On Mon, Nov 16, 2009 at 1:47 AM, Duncan Coutts
> <duncan.coutts at> wrote:
> > package authors,
> >
> > I'm preparing to release two new versions of cabal-install.
> >
> Does this new version happen to work with the GHC 6.12 release candidate?

Version 0.8 will do (the current darcs 0.7.5 works with it already).

Version 0.6.4 may or may not, depending on how difficult it is to hack
it. If it does, it'll probably only work well enough to let you "cabal
install cabal-install" and will probably prompt you to do so frequently.
If not, then it'll just break with a better error message.


More information about the Libraries mailing list