problems encountered installing/upgrading Cabal

Bertram Felgenhauer bertram.felgenhauer at
Sun Jun 21 12:37:38 EDT 2009

Iain Barnett wrote:
> I want to install Cabal library on OSX 10.4.11. Unfortunately, none 
> of my attempts so far appear to have worked. I already had but it 
> wouldn't upgrade when running "cabal upgrade", it just hangs.
> iainb$ cabal --v
> cabal-install version 0.5.1
> using version of the Cabal library
> first attempt:
> iainb$ darcs get
> iainb$ sudo sh
> Setup: At least the following dependencies are missing:
> Cabal >=1.7.2 && <1.9

The darcs version relies on an unreleased version of the Cabal library.
(If you want to go that route, it's available from )

> second attempt; I downloaded the tarball from 

Good so far.

> iainb$ cd Cabal-
> iainb$ sudo runhaskell Setup configure --prefix=/usr/local/
> iainb$ sudo runhaskell Setup build
> iainb$ sudo runhaskell Setup install
> Installing library in /usr/local/lib/Cabal-
> Registering Cabal-
> Reading package info from "dist/installed-pkg-config" ... done.
> Saving old package config file... done.
> Writing new package config file... done.
> iainb$ cabal --v
> cabal-install version 0.5.1
> using version of the Cabal library

That's the library cabal-install was compiled and linked against.
You'll have to reinstall cabal-install as well.

Does  cabal install --global cabal-install  work?

Btw, if you have installed cabal-install with --user (which is the
default), the binary will be in ~/.cabal/bin , which you can add to
your PATH.

Otherwise, pick up the latest release from

and compile it manually.

> If I run "ghc-pkg list" then it displays:
> /usr/local/lib/ghc-6.8.3/package.conf:
>     Cabal-, Cabal-, ...
> /Users/iainb/.ghc/i386-darwin-6.8.3/package.conf:
>     Cabal-, ...

That part looks good. Note that you have two installations of the Cabal
library, one global and one user installation.



More information about the Libraries mailing list