exposing hidden packages with runghc

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Sat Jul 4 09:37:21 EDT 2009

On Sat, 2009-07-04 at 13:17 +0100, Iain Barnett wrote:

> 2009/7/2 Duncan Coutts <duncan.coutts at worc.ox.ac.uk>

>         Do you have any more details on that? What problem are you
>         hitting
>         exactly? A log file would help us see what's going on. I did
>         test
>         ghc-6.8 when releasing Cabal-1.6 and cabal-install-0.6.2.
>         Duncan
> Which log files would be helpful? From looking at "ps ax" when it was
> running it seems that the linking (ld) part of the install is the bit
> that takes a long time. About 8hrs on this machine, 

Wow. That's crazy. I've never seen that before. It should be a few
seconds at most, especially since it's not using "split-objs".

> whether I used 

>      1. ghc --make Setup  
>      2. ./Setup configure --user  
>      3. ./Setup build
> or subsequently 
>      1. ./dist/build/cabal/cabal update  
>      2. ./dist/build/cabal/cabal install cabal-install
> Just let me know what you need, and I'll be happy to try a fresh
> install to recreate the problem if needed - once I've backed up this
> one!

Did you say this was an ordinary Debian install? What version, what
hardware platform?

What version of binutils was that? Was ld using a massive amount of
memory? Was it using an amount of memory that pushed everything into
swap? Presumably it's the final link that is taking so long, not
compiling and linking Setup.hs ?


More information about the Libraries mailing list