Proposal #2659: Add sortOn and friends to Data.List

Isaac Dupree isaacdupree at
Wed Oct 15 16:06:27 EDT 2008

apfelmus wrote:
> but I don't like the name. In particular I don't like the "get" prefix
> in "getDown". I'd simply use
>   newtype Desc a = Desc a

what's up with "Down", "Descending" etc.?  "Ord" is a 
symmetric, mathematical concept, no more "ascending" than 
"descending"!  It's just a convention (created/used by 
functions like "sort") to sort ascending, and it annoys me a 
little that they're not called "sortAsc" (sortAscending) to 
say what they do.  I'd suggest something like "ReverseOrd" 
or "ReverseOrder", (or "Opposite..."?) (or some abbreviated 


More information about the Libraries mailing list