cabal-install, ghc-6.10

Duncan Coutts duncan.coutts at
Wed Oct 8 13:27:34 EDT 2008

On Wed, 2008-10-08 at 10:01 +0200, Johannes Waldmann wrote:
> Does cabal-install work with ghc-6.10? Not out-of-the box it seems.
> With a recent 6.10 binary snapshot (containing Cabal-1.5.5), I get
> Configuring cabal-install-0.5.2...
> Setup: At least the following dependencies are missing:
> Cabal ==1.4.*, HTTP >=3000 && <3002, base <3 && >=2.0 && <2.2

You need the latest darcs version of cabal-install if you want to use it
with ghc 6.10. Besides working with the latest version of the Cabal lib
(which is what comes with 6.10) there are also some important changes to
the dependency resolver that enable it to cope with the fact that
ghc-6.10 has two versions of the base library.

Both versions of base often need to be used within a single install
plan. Previously this would have violated our definition of a consistent
install plan.


More information about the Libraries mailing list