Cabal on Debian Stable/GHC 6.6

Jochem Berndsen jochem at
Tue Jun 24 07:33:20 EDT 2008

On Tue, 2008-06-24 at 11:53 +0100, Duncan Coutts wrote:
> I cannot reproduce this. I tried on the community server which is debian
> 4.0 (which I think is etch right?). It was using ghc-6.6. I tried with
> Cabal- and bimap from hackage.

4.0 is etch, indeed. 

> > ghc in my sid (debian unstable) chroot gave "6.8.2". Maybe Cabal 1.4
> > doesn't like versions of the form x.y, only of the form x.y.z (wild
> > speculation)?
> No, that should be fine. It's parsing a Version so that can be any
> sequence of digits separated by dots.
> > By the way, compiling the Setup.lhs-file of bimap and running it does
> > work:
> > 
> > jochem at huygens:/tmp/bimap-0.2.2$ ghc --make Setup.lhs -o Setup
> > [1 of 1] Compiling Main             ( Setup.lhs, Setup.o )
> > Linking Setup ...
> > jochem at huygens:/tmp/bimap-0.2.2$ ./Setup configure
> > Configuring bimap-0.2.2...
> > jochem at huygens:/tmp/bimap-0.2.2$ 
> That's pretty weird. Are you sure ghc and runghc are the same version?

Yes, the only version I ever installed on that machine is ghc 6.6 from
the Debian archives. Also, there exists a symlink /usr/bin/runghc
-> /etc/alternatives/runghc -> /usr/lib/ghc-6.6/bin/runghc. 

I can't reproduce the problem on my laptop (debian etch) as well.
Adding some debug output in Cabal seems to reveal the problem:
waitForProcess, when called from rawSystemStdout, throws an exception:

waitForProcess: does not exist (No child processes)

Reinstalling the ghc6 package, reinstalling filepath and cabal did not
fix this problem. Any idea? I guess it is outside the realm of Cabal. 

Jochem Berndsen | jochem at

More information about the Libraries mailing list