Cabal on Debian Stable/GHC 6.6

Duncan Coutts duncan.coutts at
Tue Jun 24 06:53:04 EDT 2008

On Tue, 2008-06-24 at 12:07 +0200, Jochem Berndsen wrote:

> jochem at huygens:/tmp/bimap-0.2.2$ runghc Setup.lhs configure -v3
> Configuring bimap-0.2.2...
> Creating dist (and its parents)
> searching for ghc in path.
> found ghc at /usr/bin/ghc
> ("/usr/bin/ghc",["--numeric-version"])
> Warning: cannot determine version of /usr/bin/ghc :
> ""
> Setup.lhs: ghc version >=6.4 is required but the version of /usr/bin/ghc
> could
> not be determined.
> jochem at huygens:/tmp/bimap-0.2.2$ ghc --numeric-version
> 6.6
> jochem at huygens:/tmp/bimap-0.2.2$

I cannot reproduce this. I tried on the community server which is debian
4.0 (which I think is etch right?). It was using ghc-6.6. I tried with
Cabal- and bimap from hackage.

> ghc in my sid (debian unstable) chroot gave "6.8.2". Maybe Cabal 1.4
> doesn't like versions of the form x.y, only of the form x.y.z (wild
> speculation)?

No, that should be fine. It's parsing a Version so that can be any
sequence of digits separated by dots.

> By the way, compiling the Setup.lhs-file of bimap and running it does
> work:
> jochem at huygens:/tmp/bimap-0.2.2$ ghc --make Setup.lhs -o Setup
> [1 of 1] Compiling Main             ( Setup.lhs, Setup.o )
> Linking Setup ...
> jochem at huygens:/tmp/bimap-0.2.2$ ./Setup configure
> Configuring bimap-0.2.2...
> jochem at huygens:/tmp/bimap-0.2.2$ 

That's pretty weird. Are you sure ghc and runghc are the same version?


More information about the Libraries mailing list