Broken packages on hackage

Spencer Janssen sjanssen at
Wed Jun 18 03:44:04 EDT 2008

On Tue, Jun 17, 2008 at 04:26:06PM -0700, Don Stewart wrote:
> Just did a full run over hackage, building packages with ghc 6.8.2,
> bytestring and cabal 1.4.1..
> Several hundred packages built fine.
> The majority are relatively easy to fix, if the upstream authors
> can be contacted.
> The following could be marked broken, if we could do that.

I tried building a few of these packages, and my results mostly agree.

>         dataenc

dataenc 0.11 works for me.

>         hslogger

hslogger 1.0.5 works for me (in fact all of the versions on hackage seem to
support split base).

>         special-functors (needs base<2 !)

This is explicitly marked as a compatibility package for old GHC versions --
base<2 is intentional.

>         Monadius            -- missing: extra-libraries: glut
>         shu-thing           -- missing: extra-libraries: glut

Both of these build and run here.  I don't understand why they should have
"extra-libraries: glut", don't the extra-libraries belong in the GLUT package

>         storablevector      -- QC arbitrary missing Control.Monad.Instances

Builds fine here.  However, the tests should not build for a Hackage release,
I'll look into this.

Spencer Janssen

More information about the Libraries mailing list