[Haskell] Re: Trying to install binary-0.4

Ketil Malde ketil+haskell at ii.uib.no
Thu Oct 25 06:31:05 EDT 2007

Simon Marlow <simonmarhaskell at gmail.com> writes:

> http://hackage.haskell.org/trac/ghc/wiki/PackageCompatibility

> It's been helpful for me to write all this down, the issues seem much
> clearer.  However, I don't see an obviously best solution.  For me
> proposal 4.2 (see the wiki page) looks the most promising, but it
> doesn't provide complete backwards compatibility, so I imagine there
> will be people who disagree.

The section "The problem of lax version dependencies" refers to
"Solution 3", which doesn't seem to exists. Presumably "Solution 2" is meant?

Wouldn't keeping "base-2.0" and rebranding "base-3.0" to
"foundation-1.0" (which might be listed as "Solution 2.1") solve this

If I haven't seen further, it is by standing in the footprints of giants

More information about the Libraries mailing list